Welcome to the Corvette Forums at the Corvette Action Center!

Vibration problem solved at last!!

6

69vettester

Guest
I think I read around 20-30 posts about the difficulty in finding and fixing drive train vibrations.
I was beginning to think that the dreaded vibration at 70-80 mph was an inherent problem that comes with owning a C3 vette. Its not..My car now accelerates through the gears and runs up to a 100 just as smooth as silk.

Heres what happened
I had replaced all the ujoints and rear wheel bearings sometime back, while this helped overall, it did not solve the problem.
Last week I decided to after it again with renewed gusto. rebuild or replace everything from the pilot bushing to the front carrier yoke. balance the driveshaft and resurface the flywheel

Heres what I found...
The slip yoke was "badly" worn (eggshaped) . this and an unbalanced driveshaft was 95% of the problem with my car. As soon as I pulled that yoke out of the tranny extension, I said "Woilla" this has got to be it, no way the driveshaft could spin true with that yoke flopping. To be honest though, It got that way to begin with, because the driveshaft wasnt correctly balanced and I drove the car for 30 thou. with it off balance :eek:
So what can I say cept..."uh, moving on":gap
so I got a new spicer slip yoke, and a seal,..

But get this..the bushing was fine??go figure??Im not real clear about how that yoke could get like that without wiping out the tranny extension bushing too??but it didnt? Any comments from the Pro's and Gurus about this??

The bonus was, I was going to rebuild the muncie , using a kit from zips, and saw there was no reason too :Twist

The clutch was worn out too ,pressure plate scored, disk worn almost to the rivits, worn out ball stud moving in the fork seat, slightly damaging the fork. It was not a pretty sight but was just starting to fail..yikes..
I replaced it all with new, not reman. stuff.

Chris..I Fixed my oil leak while I was at it..Turned out the rear mainseal is fine, the pan gasket (rear neck cork) was letting oil flow right out, to the tune of a qt. in 700-800mi.
for an entire year, (cause I was sure it was the rear mainseal and I didnt want to the rear main cap..).

I got it all back togeather a few hours ago and took it out for highway cruise...
I am completely stoked about the whole thing..this was the most worthwile time Ive spent on the 69. I kid you not its absolutely smooth through the gears and on up to 4500rpms. Not a vibration in the peddle or shifter , no shakes shimmies shudders anywhere, drives like a new car.

Im Getting inspired for a new road trip now..sharkfest is looking more doable all the time...

Take care all..
Tom
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom