Welcome to the Corvette Forums at the Corvette Action Center!

WHY won't A/C work?!!! Tech doesn't know.

vee93

Well-known member
Joined
Nov 15, 2002
Messages
585
Location
Mississippi
Corvette
1993 Medium Quasar Blue Metallic Coupe
Do y'all? Can someone help me help these techs, PLEASE!!!
Switched out the head unit cause it wasn't registering any power.
A/C worked for a day and a half.
New fuses.
Diode at compressor new.
Compressor good.
After that day and a half of air--pushing the buttons turned on the compressor w/ fans running fine--but no cold air coming thru vents.
Push the buttons now--nothing.
Yes, I have the service manuals for my '93.
I'm trying not to have to tell these people their business, but..., my patience is wearing out.
Thanks all for any info, ideas, etc..., you send my way. :w
 

larryk87

New member
Joined
Jul 20, 2004
Messages
1
Location
Englewood, Fl
Corvette
1987 Black Rose Coupe
Do y'all? Can someone help me help these techs, PLEASE!!!
Switched out the head unit cause it wasn't registering any power.
A/C worked for a day and a half.
New fuses.
Diode at compressor new.
Compressor good.
After that day and a half of air--pushing the buttons turned on the compressor w/ fans running fine--but no cold air coming thru vents.
Push the buttons now--nothing.
Yes, I have the service manuals for my '93.
I'm trying not to have to tell these people their business, but..., my patience is wearing out.
Thanks all for any info, ideas, etc..., you send my way. :w

Start with the following:
1. is the system charged enough to allow the compresser to "turn on" 190 or higher Psi static pressure. ( compresser NOT engaged )

2. does the Low Pressure switch test good.
3. Pressure readings:
a. Low side, compresser engaged, pressure greater than 25psi
b. High side compresser engaged, pressure greater the 170 psi

4. blower Fan is running, and air movement is felt at vent openings

BTW you can get an acceptable set of gauges from Autozone as a "Loan A Tool" so you dont need to buy a set, just a returnable deposit when you bring them back. This will help a great deal in hunting down your problem.
 

Robertwav1

Well-known member
Joined
Jan 7, 2003
Messages
819
Location
Ocala, Florida
Corvette
1993 Blue
Do y'all? Can someone help me help these techs, PLEASE!!!
Switched out the head unit cause it wasn't registering any power.
A/C worked for a day and a half.
New fuses.
Diode at compressor new.
Compressor good.
After that day and a half of air--pushing the buttons turned on the compressor w/ fans running fine--but no cold air coming thru vents.
Push the buttons now--nothing.
Yes, I have the service manuals for my '93.
I'm trying not to have to tell these people their business, but..., my patience is wearing out.
Thanks all for any info, ideas, etc..., you send my way. :w
You mentioned "push the buttons". Do you get the little green LED's light up when you push them or no?

Post any other info you may have.
 
Joined
Jul 4, 2007
Messages
19
Location
Viva Las Vegas
Corvette
1985 Silver & 1987 silver
when air switch is on. does radiatir fan come on?

when you turn on ac your cooling fan should automatically come on, even when cold. if it doesn't you may have an ECM problem. there are 2 switches a cycle switch and I beleive the other is a low freon or pressure switch. I have an 85 and 87, just redid the whole ac in my 87 works perfect. If you have a halogen leak detector sniff the connections to see if leakage is occuring? If your low on freon chances are the compressor wont cycle on, if it does, see if the electric fan(s) are coming on, if they do, you might have problem with head unit or connections behind it?

good luck, give some more feedback to above answers and mine, can eliminate more things that way..
 

vee93

Well-known member
Joined
Nov 15, 2002
Messages
585
Location
Mississippi
Corvette
1993 Medium Quasar Blue Metallic Coupe
Yeah, the green light blinks. I've checked the control head unit for codes and the only DTC it's showing is 09 (low freon detected).

I asked the tech to refill the freon and check for a leak, if there's a leak-fix that first and he'll have enough pressure to run the compressor. Do this first so as not to fry my compressor.

I tried asking/telling tech to disconnect the neg. battery cable to clear any false codes. Push an A/C button and if the green light blinks. Wait for it to stop. Then do the on board control head test. If he gets the blinky greeny, he'll get a DTC reading. If the compressor doesn't come on, to check the ECM for codes 66-69. Those codes stored in the ECM will tell him if its a pressure sensor circuit problem, a shorted out circuit, A/C clutch circuit problem or an open circuit. And to proceed from there before rooting around on some clueless, $65 per hr. hopeful hunt.

He keeps insisting he needs to pull the control head unit (again--which they replaced) to root around with the 'effin wiring. :hb

I have given them until Tuesday. No fixy by then and I'm getting my $$$ back.

Oh, did I mention coolant leaked outta it over the Labor Day weekend while I was detailing the car.:mad I couldn't quite pinpoint the source other than the left, top end of the radiator. *sigh* Some 'eff up on their part. I'm thinking when they drained and refilled the dang system, somebody didn't release the bleed valves and there was an overfill. They cannot tell me it's the waterpump cause the car never would've cranked.

Lord knows I wish I could do this myself.;help I'm just hoping to God I don't have to go back on my word and *gulp* take the car to the dealership!!!:eek:hnoes
 

Robertwav1

Well-known member
Joined
Jan 7, 2003
Messages
819
Location
Ocala, Florida
Corvette
1993 Blue
When gauges are put on the system static pressure is a good indication of how low the freon is. Your code indicates "low gas", I would go with that first. It's probably low. Whether you developed a leak or the system has gone low over time would be what i want to know. All systems leak! It's the rate of the leak that's important. This is a 93, so, it's quite possible it went low enough to trip out the low pressure sensor. Another question I would ask would be have you noticed the AC not quite as cold as it use to be this year? You haven't mentioned what the gauges said? They replaced the AC control unit?

You need to have someone tell you if it's low on gas or not.

Also, check the ground for the AC clutch relay, it's on the middle right hand side of the engine compartment on the frame rail. Take it off and clean it.

The pressure sensors are easy enough to check with a meter, they should be closed. If not, a low on gas situation could be or, a sensor could be bad.

Everything is in the service manual, diagnostic procedures etc ... a lot's involved but a good tech should be able to find out what's wrong.
 

vee93

Well-known member
Joined
Nov 15, 2002
Messages
585
Location
Mississippi
Corvette
1993 Medium Quasar Blue Metallic Coupe
Well, here's an update on my Vette problems--they just got worse!!

Got a call today from the garage mgr. and he tells me that the ECM is toast-- it isn't registering any voltage on the diagnostic tool. I'm screwed in more ways than I care to count. To top it all out, my daily driver--the Z24 Cav, died on me today and I was sitting in it comtemplating a lot of ugly when I got the call about the Vette.

1ST-- No new ECMs for sale ANYWHERE. GM has discontinued the part and have no plans to farm the work out to an aftermarket company to produce replacements.
Thanks, GM.

2ND-- from way back when the Vette was at the body shop, the original ECM was damaged and replaced then. Those *ssholes swapped my ECM out and according to the #s on the one in the Vette now, its from a Firebird. Of all the trouble I had with that particular body shop, that's the one doublecrossing possibility I forgot to check. They probably took mine and sent it somewhere and kept the sale/core charge. Nice, huh?

3rd-- the few places I've found that have remanufactured ones for sale want core chg. + my ECM - the PROM. How's that gonna work out if I have a Firebird ECM and I'm wanting a Vette one in exchange? G*DDAMMIT!!!

On top of that, the A/C wasn't fixed, there's coolant coming from somewhere near the top-left of the radiator and I'm just about ready to rip my hair out.

Anybody know of where I can get an ECM for a '93 automatic coupe?
God knows I'd be in your debt forever!
 

Robertwav1

Well-known member
Joined
Jan 7, 2003
Messages
819
Location
Ocala, Florida
Corvette
1993 Blue
Yea ... that really sucks. Did the ECM run the car okay before? If it did you could send it out for repair at Mid America for $120.00. I believe you have to remove the EPROM first. Another option.
Radiator problems also? Hoses replaced? I just did all of mine and by the way the smaller bypass hose you can't get anymore. Have to get the right size hose and use one of those stainless steel wire coil thingy's to keep the hose away from one of the pulley's. In case you have to replace radiator and do new hoses, figured I'd let ya know. Good Luck, keep us posted!
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
ECM

A bit of a longshot

Sport Imports North Hollywood CA 818 765-3333

Ask for George
Tell him year/ options / and he MIGHT have a full ECM W Prom // used

He's a wrecking yard.. and a bit of an Armeanian ( sp ?) grinder

But it's worth a shot

Vig~
 

vee93

Well-known member
Joined
Nov 15, 2002
Messages
585
Location
Mississippi
Corvette
1993 Medium Quasar Blue Metallic Coupe
Well...
After 17hrs. of searching the Internet, 4 hrs. on the phone and a few emails, I finally tracked down and bought a remanufactured ECM. Actually I found more than one, bought two from different companies.

Question:
Once the negative battery cable is disconnected, that clears any codes in the chip and my Vette's data is still stored, correct? So all I need to do is take my old chip and put it in the new ECM and I'm good to go, right?
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
Remove power to the ECM

Codes go away.. when you wake the ECM up BEFORE you start the car.. check that you have no codes as well.

Vig~
 

vee93

Well-known member
Joined
Nov 15, 2002
Messages
585
Location
Mississippi
Corvette
1993 Medium Quasar Blue Metallic Coupe
Finally found a remanufactured (and warrantied) ECM from Standard. The chip from my old ECM was put in the car and it ran well. A/C is blowing cold. Radiator leak fixed.
That was first day the new ECM was installed. Next day, the shop mgr.cranks it up for one last test run b4 calling me to pick it up and it started to run badly, then cut off. He cranks it up again and the check ASR light comes on the Information Center. He says the 3rd-4th time he cranked it again it idled and ran fine. However..............
Two problems arose--
1. The interior lights would not shut off.
2. The fan comes on as soon as the Vette is cranked up.
So. The Vette is STILL at the dang shop. Still.
 

onedef92

Well-known member
Joined
Jun 12, 2004
Messages
214
Location
Louisville, KY
Corvette
1992 Dark Red Coupe
Finally found a remanufactured (and warrantied) ECM from Standard. The chip from my old ECM was put in the car and it ran well. A/C is blowing cold. Radiator leak fixed.
That was first day the new ECM was installed. Next day, the shop mgr.cranks it up for one last test run b4 calling me to pick it up and it started to run badly, then cut off. He cranks it up again and the check ASR light comes on the Information Center. He says the 3rd-4th time he cranked it again it idled and ran fine. However..............
Two problems arose--
1. The interior lights would not shut off.
2. The fan comes on as soon as the Vette is cranked up.
So. The Vette is STILL at the dang shop. Still.

Intermittent problems SUCK! ;shrug
 

fatboyreyn

Well-known member
Joined
Aug 31, 2006
Messages
116
Location
east coast
Corvette
1986 red
ecm bad

Well, here's an update on my Vette problems--they just got worse!!

Got a call today from the garage mgr. and he tells me that the ECM is toast-- it isn't registering any voltage on the diagnostic tool. I'm screwed in more ways than I care to count. To top it all out, my daily driver--the Z24 Cav, died on me today and I was sitting in it comtemplating a lot of ugly when I got the call about the Vette.

1ST-- No new ECMs for sale ANYWHERE. GM has discontinued the part and have no plans to farm the work out to an aftermarket company to produce replacements.
Thanks, GM.

2ND-- from way back when the Vette was at the body shop, the original ECM was damaged and replaced then. Those *ssholes swapped my ECM out and according to the #s on the one in the Vette now, its from a Firebird. Of all the trouble I had with that particular body shop, that's the one doublecrossing possibility I forgot to check. They probably took mine and sent it somewhere and kept the sale/core charge. Nice, huh?

3rd-- the few places I've found that have remanufactured ones for sale want core chg. + my ECM - the PROM. How's that gonna work out if I have a Firebird ECM and I'm wanting a Vette one in exchange? G*DDAMMIT!!!

On top of that, the A/C wasn't fixed, there's coolant coming from somewhere near the top-left of the radiator and I'm just about ready to rip my hair out.

Anybody know of where I can get an ECM for a '93 automatic coupe?
God knows I'd be in your debt forever!

First and foremost, punt your mechanic. If I had a nickel everytime somebody replaced and ECM, only to find out it wasn't the problem. Buy the way, if you go online to a salvage yard search site, you will find vet ECM's are definatly still around for about a hundred bucks. Unless your mechanic fried the ECM, I don't think thats your culprit. get a halogen leak dector and find the leak!!!!!1
 
M

marty.g

Guest
not to add to your delema, but i tried taking my 96 to the dealer for something and they told me they don't work on anything 10yrs or older
 

vee93

Well-known member
Joined
Nov 15, 2002
Messages
585
Location
Mississippi
Corvette
1993 Medium Quasar Blue Metallic Coupe
I just don't trust the dealers in my area. Last time I took the Vette to them (which I detailed in an earlier post on the CAC) for a simple oil change, they put the wrong weight oil in the car-which I didn't notice until I was balancing my checkbook and looking over the bill. The service manager had the nerve to ask me what I expected them to do about it. Jeez!

So, the Vette is now out in the garage. After 7 muthaf*cking months, it runs. The A/C problem is supposedly fixed, but now that its cold outside, I haven't really bothered to run it for a lengthy amount of time. Before the cold snap here, I did run the A/C on the way home and noticed the 'SYS' blinked for a while. I haven't seen it since, but I really haven't had the time or wherewithall to put the Vette thru its paces yet. The day I brought it home, I later decided to drive it up to warming speed and the d*mn thing wouldn't crank. I charged the battery, drove it around the neighborhood for about 20 minutes then returned to the house and parked it.

When I picked the car up last weekend, I did a walk around. The targa top is scratched, as is an OEM replacement wheel- 1 of 4 I bought off eBay. The shop owner offered to have the scratches buffed out. I told him, no. I will get repair estimates and deduct those amounts from his charges. The passenger door lock cylinder is now broken and the passive key system doesn't snick the doors open when I walk near the car after its sat for a while. The interior lights still do not come on-a direct result of the broken door lock and the malfunctioning alarm system.

The ECM and the HVAC units were replaced. I have them at the house--to be tested later. If I find they are not faulty, I will get my $$$ back.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom