Welcome to the Corvette Forums at the Corvette Action Center!

1976 Stingray Tach doesn't work!

J

Jade

Guest
The tach doesn't work! What should I look for and is this a simple or complex problem?
 

barrier5

Well-known member
Joined
Dec 27, 2001
Messages
126
Location
janesville wi usa
Corvette
1982 bright blue coupe
Check the plug at dist. cap,check the plug and circuit panel on the back of the speedo cluster,or you might need a new circuit board,50 or 60 bucks from Ecklers.Good Luck
 

Jack

Well-known member
Joined
Dec 27, 2000
Messages
1,825
Location
Florence, SC (Timmonsville SC)
Corvette
71 War Bonnet Yellow VERT 71 BH Blue CPE (SOLD)
ditto

Jade:
Your tach's electronic ... and barrier5's got both correct idea & sequence for checking. Let us know what you find?
JACK:gap
 
K

k9judge

Guest
Hello
Just came online seen your post. I just replaced the board on the back of my tach on my 76 also white coupe. its not a one afternoon job. Nothing hard just tons of patience. Your dash is going to have to come out and you might as well replace the speakers at this time to and redo all the light bulbs behind there too while you got it out. Baers in PA has the parts too, good luck
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom