Welcome to the Corvette Forums at the Corvette Action Center!

3 Bad Fuel Pumps. Why?

96LT4Z15

New member
Joined
Apr 18, 2020
Messages
3
Location
Owens Crossroads, AL
Corvette
1996 CE LT4
Last April the Forum helped me determine I had a BAD FP, in my 96/LT4, with 2-3sec priming pulse at the connector at fuel tank, the pump would not run. Removed it and tested it..was bad! So, since that time I replaced the FP, TWICE!! All pumps were AC Delco. Each ran great for a few month, then died. All symptoms are the same. Well I'm there again. Vette won't start and I have the 12vdc at the tank connector for 2-3 sec...What's the problem? Looking forward to hearing from you!
 

Hib Halverson

Technical Writer for Internet & Print Media
Joined
Jan 10, 2001
Messages
13,453
Location
CenCoast CA
Corvette
71 04 12 19
With the key on the pump will only run for a few seconds and if the ECM does not sense oil pressure, it cuts the pump off.

Do you have the 1996 Factory Service Manual?
 

96LT4Z15

New member
Joined
Apr 18, 2020
Messages
3
Location
Owens Crossroads, AL
Corvette
1996 CE LT4
With the key on the pump will only run for a few seconds and if the ECM does not sense oil pressure, it cuts the pump off.

Do you have the 1996 Factory Service Manual?


Yes, I have the FSM. It doesn't run for 2-3 seconds when the key is set to ON, but I have 12 Vdc at the plug on the chassis side of the harness.
 

rhandle

Active member
Joined
Apr 23, 2009
Messages
28
Location
boca raton
Corvette
1996 grand sport
I am currently on my 4th fuel pump. The last one was in for only 6 months when it died When i removed it ,ALL THE WIRING WAS RUSTED OFF as well as the pump. This is all from ETHANOL gas. You ,like I probably let it sit alot. You need to purchase upgraded wiring for the sending unit as well as a pump that is compatible with E85. Then use ethanol free gas only. WAWA sell it. I had great luck with RACETRONIC. Just get a whole new sending unit. I think either Eclers or MID America catalog states that their unit is upgraded and resistant to ethanol. I have the LT4 also and no one believed that i went thru that many pumps
 
Last edited:

96LT4Z15

New member
Joined
Apr 18, 2020
Messages
3
Location
Owens Crossroads, AL
Corvette
1996 CE LT4
I am currently on my 4th fuel pump. The last one was in for only 6 months when it died When i removed it ,ALL THE WIRING WAS RUSTED OFF as well as the pump. This is all from ETHANOL gas. You ,like I probably let it sit alot. You need to purchase upgraded wiring for the sending unit as well as a pump that is compatible with E85. Then use ethanol free gas only. WAWA sell it. I had great luck with RACETRONIC. Just get a whole new sending unit. I think either Eclers or MID America catalog states that their unit is upgraded and resistant to ethanol. I have the LT4 also and no one believed that i went thru that many pumps

Thanks for all the info...for some reason a didn't receive an email that you had responded. I was beginning to think I was the only person with this issue. I will take you advise and replace the entire unit and see how she goes.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Win Both Corvettes!

Win Both Corvettes and Get Extra Bonus Tickets Now!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Dead Center Foundation

Vetteskins

Advertise with the Corvette Action Center!

Partners

Top Bottom