Welcome to the Corvette Forums at the Corvette Action Center!

AC ok, but air dosnt come from front panel.

S

string

Guest
Hi,

I just started my ac today and found that the air just dosnet flow from the front panel, read the climate control and everything seems ok. is there a chute or vent thas's stuck??

can some one feel me in?

I have a '94 vette.

Thnks
String
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
No suck

Vacume controls the positions of the vents.
Open the hood and visually inspect all the vac lines running around. Going to bet one is broken,loose, toast.

The vac feed for your stuff comes off the right side of the Plenumn next to the fuel pressure regulator.

BUT ANY LEAK can make the whole vent system act weird.

Check EVERYTHING.


Mike
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
Oops 94

Does the AUTO ( or any other MODE) light flash for 60 seconds when you start the car?


Check my previous postings about Doug's heater.


Mike
 
S

string

Guest
Thnks ...

Hello, alll the mode light are ok (nothing flahses) , BUT the vacum valve is broke. tried to fix, and noticed that now the air flows from the front panel. Now I'll be going to the shop to buy a new vacum valve.


a big thank you to everyone!!

String
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
For now

Just buy a "T" fitting from your local auto parts store & some vac line.

I assume the grey vac fitting by the rear of the block disintergrated.


In a pinch.. I take the hard plastic line cut it back a bit, slip some regular vac line to & from it, ty wrap the end and put a small bead of glue around the junction.


It's a little BUBBA... but it works


Good Luck

Mike
 

KOPBET

Well-known member
Joined
Jan 31, 2003
Messages
1,355
Location
Tulsey Town
Corvette
'73 Silver LS4 4 speed
I am having the same problem and its hitting 90's in NJ. NO air from the center vents really hurts. Where is the vacuum value located? Under the plastic value covers on the passenger side?

Is this what i should be looking for?

http://www.ecklers.com/product.asp?pf_id=28618&dept_id=1183

Yep. High failure rate on that part it seems. It's under the right side fuel rail. If that part is broken, the cruise won't work either. Seems like it was about 6 bucks at the dealer so I would buy locally and save the shipping costs.
 

JohnnyC

Well-known member
Joined
Jul 5, 2002
Messages
259
Location
NJ
Corvette
1996 Black Coupe - LT4
Anything else? I got the vacuum check valve. The old one did have a big hole in it and two of the ends had snapped off into the hoses. Installed it, but i'm still not getting any air out of the front vents, just the defroster and by feet. Should I be checking all those hoses for possible leaks?
 

JohnnyC

Well-known member
Joined
Jul 5, 2002
Messages
259
Location
NJ
Corvette
1996 Black Coupe - LT4
AIR WORKS!!!!!!!!!!!! I guess I didnt give the air enough time to get working last night. This morning, i started the Vette up and COLD AIR blew right on me. It worked! It was great! The little vacuum check value worked. $8.39 fix! Thanks.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom