Welcome to the Corvette Forums at the Corvette Action Center!

Ambient outside temp not working

0

0utlaw

Guest
Hello all.
I am a newbie and I need some help. I had my radiator and stat replaced this week and since then, my outside temp only reads 50 degrees. I took it back to the radiator shop who did the work and they had forgotten to plug the wire back into the sensor under the front of the car. After plugging it back in, the dash still only reads 50 degrees. They said maybe the computer needs to be reset.

I don't know if that is the problem or not. Any help would be greatly appreciated.

Thanks,
0utlaw
 

Rabbit

Well-known member
Joined
Dec 19, 2001
Messages
956
Location
sonoma ca usa
Corvette
2004 C5 coupe, MSGM & 2014 Cad SRX Crystal red
Don't know if this will work, but try disconnecting the battery for a couple of minutes.
 
R

rbyrne

Guest
Had that sensor go bad on the bride's GTP last week. Cost about CAN$12 which is about US$1.50. Works like a charm now. She's as cool as a cuke.
 
0

0utlaw

Guest
Thank you all for your help. Turned out that after the wire was connected back to the sensor, and the car sat for 8 hours while I was at work, when I started her up, the outside temp started registering properly. Been ok now for 4 days.
 

Spurley

Member
Joined
Jun 5, 2020
Messages
5
Location
Grand Rapids
Hello Any chance you remember what color the wires were coming from the dash that you connected the sensor plug into?
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Win Both Corvettes!

Win Both Corvettes and Get Extra Bonus Tickets Now!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Dead Center Foundation

Vetteskins

Advertise with the Corvette Action Center!

Partners

Top Bottom