Welcome to the Corvette Forums at the Corvette Action Center!

digital readout problem - 1991

Red73BB

Well-known member
Joined
Jun 15, 2001
Messages
241
Location
Defiance, MO
Corvette
1969 dark red convert
Friends,

My 91 wouldn't start ( dead battery - sat too long ) so I jump started with no problem.

However

The digital readout - speedometer, gas gauge - doesn't read correctly or doesn't display at all.

The digital readout was working just fine before the dead battery. After I jumped it, I took it for a drive and about 10 miles into the drive the problem appeared.

can anyone help? have you seen this before?

Gary
 

gmjunkie

Well-known member
Joined
Nov 11, 2004
Messages
4,547
Location
Old Fort NC/Vero Beach FL
Corvette
03 Z-51,78 L82 Coupe
Friends,

My 91 wouldn't start ( dead battery - sat too long ) so I jump started with no problem.

However

The digital readout - speedometer, gas gauge - doesn't read correctly or doesn't display at all.

The digital readout was working just fine before the dead battery. After I jumped it, I took it for a drive and about 10 miles into the drive the problem appeared.

can anyone help? have you seen this before?

Gary
Make sure that your battery is charged good!!!Remove the neg battery cable for 5 min and reconnect!!! Lets see if this fixes it!!!!;) :upthumbs :D
 

Red73BB

Well-known member
Joined
Jun 15, 2001
Messages
241
Location
Defiance, MO
Corvette
1969 dark red convert
I can do that - what does that do? resets all instruments?
 

gmjunkie

Well-known member
Joined
Nov 11, 2004
Messages
4,547
Location
Old Fort NC/Vero Beach FL
Corvette
03 Z-51,78 L82 Coupe
I can do that - what does that do? resets all instruments?
Reboots the ECM!!! Dead battery's and Jump starting can make a ECM do all sorts of Weird things!!!:upthumbs
 

gmjunkie

Well-known member
Joined
Nov 11, 2004
Messages
4,547
Location
Old Fort NC/Vero Beach FL
Corvette
03 Z-51,78 L82 Coupe
Thanks - GM

ECM = Electronic Computer Module?
Electronic Control Module, Engine Control Module,Electronic Command Module, 220-221 just whatever it takes!!!!:D :upthumbs
 

gmjunkie

Well-known member
Joined
Nov 11, 2004
Messages
4,547
Location
Old Fort NC/Vero Beach FL
Corvette
03 Z-51,78 L82 Coupe
Probly wouldn't hurt to make sure the Pos and Neg Battery cable connections are Clean while your there!!!:upthumbs
 

Red73BB

Well-known member
Joined
Jun 15, 2001
Messages
241
Location
Defiance, MO
Corvette
1969 dark red convert
GM Junkie

Thanks for the tips, but still the same problem. The dash fades outs or give the wrong info. It was suggest that I change out the fuse because it could be weak. I thought either fuses worked or the didn't. The fuse was good.

Any other suggestions?
 

gmjunkie

Well-known member
Joined
Nov 11, 2004
Messages
4,547
Location
Old Fort NC/Vero Beach FL
Corvette
03 Z-51,78 L82 Coupe
GM Junkie

Thanks for the tips, but still the same problem. The dash fades outs or give the wrong info. It was suggest that I change out the fuse because it could be weak. I thought either fuses worked or the didn't. The fuse was good.

Any other suggestions?
Have your Alternator Checked out, a bad Diode can run the Battery Dead and make the Computer go Bonkers because there is AC voltage slipping past the Diodes!!! AC voltage and DC components Don't Mix well!!:upthumbs PS Check the Big Red single lead to the Alt,I've seen them corrode where the Eye attached to the wire and cause the same problem!! And it is Very hard to see because it's where the Eye attached to the Wire,not where the eye attached to the Alt. And one more thing CHECK ALL grounds!!!!!!!
 

Red73BB

Well-known member
Joined
Jun 15, 2001
Messages
241
Location
Defiance, MO
Corvette
1969 dark red convert
Junkie,

Luck yes!

Every thing I checked , all looked things good which led to more fustration.

I went to a ride yesterday and after hitting a hole in the road, the display is now back 100% bright.

So I have a lose wire somewhere, but at least I'm know the problem, now it's just fixe it!
 

gmjunkie

Well-known member
Joined
Nov 11, 2004
Messages
4,547
Location
Old Fort NC/Vero Beach FL
Corvette
03 Z-51,78 L82 Coupe
Junkie,

Luck yes!

Every thing I checked , all looked things good which led to more fustration.

I went to a ride yesterday and after hitting a hole in the road, the display is now back 100% bright.

So I have a lose wire somewhere, but at least I'm know the problem, now it's just fixe it!
It's gonna be a Ground somewhere!!!:upthumbs
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom