Welcome to the Corvette Forums at the Corvette Action Center!

gauge problem

M

my96

Guest
Can anyone help with a problem I am having with my gauges located in the speedodometer pod. Just noticed today that the numerals right next on the left of the fuel gauge keep on going on and off and 5y5 flashes on a couple times and then it goes to the correct readings like it suppose to do and then it repeats doing the same thing over and over non stop. Has anyone ever had this problem?...........I have a 96 coupe........ THANKS John ;shrug
 

Rabbit

Well-known member
Joined
Dec 19, 2001
Messages
956
Location
sonoma ca usa
Corvette
2004 C5 coupe, MSGM & 2014 Cad SRX Crystal red
What your seeing is "SYS". Do a search on that. It probably is due to a low battery or alt. problems. Hope it's that simple.
 

jmccloud

Well-known member
Joined
Feb 1, 2003
Messages
694
Location
Maryland
Corvette
1995 White Coupe LT-1 Auto
SYS indicator

My '95 flashed 'SYS' under hard acceleration shortly after I bought it in 2002. Discovered the battery was original and would go nearly dead when the door was left open for 1/2 hour or so.
New battery, no more 'SYS' indication.
Assure the battery connections are tight and clean (especially the grounds at the other end from the battery). If they're OK, have your battery checked or replaced.
Good luck.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom