Welcome to the Corvette Forums at the Corvette Action Center!

Help! 92 Airconditioner Problems

O

onegrndlaker

Guest
Airconditioner quit me while I was driving down the highway. I checked the fuse and connections, they are all good. No signs of freon leakage on any connections. Green light on airconditioner panel flashed when first started then stays on a steady green after about 2 minutes. Would appreciate any knowledge or advise on this problem. :confused:crazy
 

69MyWay

Well-known member
Joined
Jul 3, 2001
Messages
4,364
Location
Auburndale, Florida
Corvette
1969 Killer Shark
disconnect the battery, wait about 30 seconds and reconnect. This should reset the computer. Chances are you have a slow freon leak.

Let us know if this gets it going again.

Chris
 
B

BubbleHead

Guest
69MyWay said:
disconnect the battery, wait about 30 seconds and reconnect. This should reset the computer. Chances are you have a slow freon leak.

Let us know if this gets it going again.

Chris

DITTO, this is what happened to my 93. The controller prevents the compressor from engaging with low freon, otherwise you would destroy the compressor and have to shell out some serious cash.

Have it checked out. I just needed my system recharged and it's been fine all summer.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom