Welcome to the Corvette Forums at the Corvette Action Center!

Low Oil Light

supernatural400

Well-known member
Joined
Feb 25, 2001
Messages
410
Location
massachusetts
Corvette
1993 SuperNatural 400 #5 /99 LS1 Z28 N2O equipped
Came one twice so far, once when I started let it idle for a bit, shut it down,checked the oil seemed fine.started it up no light.started a couple of day's later still no light. started it today, same thing light came on,checked oil again, everything looked fine. think it's a bad sensor somewhere or maybe a clogged oil filter. Light never came on while driving only on initial start up. what do you think
 

brooks

Well-known member
Joined
Nov 22, 2000
Messages
71
Location
Los Gatos, California
Corvette
1996 GrandSport #427 1963 Red Split Window
the oil light is based on pressure not volume..oil gets thinner as it get hot. This results in lower oil pressure which results in a warning light. It would appear that you have a faulty pressure sensor or a faulty oil pump. Check the oil temp when the light comes on. mabye try to isolate it from there
 

supernatural400

Well-known member
Joined
Feb 25, 2001
Messages
410
Location
massachusetts
Corvette
1993 SuperNatural 400 #5 /99 LS1 Z28 N2O equipped
Both times that the light came on were from a cold start in the morning, never came on once the engine had been running, even after letting sit for a couple of hours. just first thing in the morning
 
C

corvettecarl

Guest
could be all your oil is blowing out your tailpipe ? ? ?
ive heard alot of the callaway's have bad ring's.
they burn alot of oil. how often does your low oil light come on ?
do you ever get a big plume of black smoke when you step on it hard?
 
L

LT4SilverEagle

Guest
When I first met you and we drove around a bit, you said you may need a valve job, remember? I think you were refering to the little bit of smoke you saw when we "took-off" on 24. Could the two things be related? Just thinking... my .02
 

supernatural400

Well-known member
Joined
Feb 25, 2001
Messages
410
Location
massachusetts
Corvette
1993 SuperNatural 400 #5 /99 LS1 Z28 N2O equipped
corvettecarl said:
could be all your oil is blowing out your tailpipe ? ? ?
ive heard alot of the callaway's have bad ring's.
they burn alot of oil. how often does your low oil light come on ?
do you ever get a big plume of black smoke when you step on it hard?

Well it turns out that it was in fact low on oil, I just recently changed, but the friggin shop put the wrong type in. So now I'll have to do it myself again. I called Callaway and talked to their Chief Engineer "Wayne".
He tell's me that during WOT the computer is set to rich to avoid leaning it out.
I did once get a big black cloud after getting on it. But black smoke is and indication of rich mixture not oil consumption, that would be a light gray smoke.
Have not noticed that I'm burning oil since the change, but I am getting a slight lifter noise now. This is because they used 5/30 instead of the 15/50
that's required. I'll be changing it this weekend to see the difference. didn't have that sound before the oil was changed so I'm assuming that it's because of the thinner oil. I did a compression check and all seemed fine on the cylinders .I don't think theres a problem with the rings and no indication of blow by.
I talked to several other people who also have Callaway's and they too are getting the same smoke sometimes at WOT, but none have encountered any problems with the rings so far.
Hopefully I'll be able to get this thing a little cooler, going to bypass the throttle body cooler and relocate the sensor.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom