Welcome to the Corvette Forums at the Corvette Action Center!

LT1 engine

R

RSmith12182

Guest
I have an LT1 that runs hot, overheats, and quits. The engine is fine idling in the driveway. But as soon as I drive it, it will quit once it hits 230 degrees. Hoses, radiator, cap, fan, etc. have all been replaced, but I still have the same problem. I can't find a mechanic in my area and would greatly appreciate anyone who knows somebody with knowledge on the LT1 who could give tips/suggestions

I have AOL and MSN instant messengers if anyone is online and would be willing to answer some questions.

Thanks,
RYAN
 
Joined
May 29, 2002
Messages
8,652
Location
Missoura Ozarks
Corvette
2012 💯 4LT GS Roadster
LT1 Questions . . .

1st - Welcome to CAC :upthumbs

What year is your Vette?

How long has this been happening and has anything new been done to the engine/car?
 
R

RSmith12182

Guest
the engine is a '96 and is completely stock. The following items have been replaced though: Hoses, radiator, cap, fan, etc.

Also if you have AOL or MSN messenger please let me know. I could probably get my questions answered quickly.

Thanks,
RYAN
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
Ryan

I have AOL...give me a shout


vigmannn is my handle.....


Vig!
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom