Welcome to the Corvette Forums at the Corvette Action Center!

No Dash Lights

lobes290

Well-known member
Joined
Sep 10, 2003
Messages
50
Location
White LK MI
Corvette
1979 white l-82
The dash lights in my 79 aren’t working. The turn indicator and high beam lights light up and all the gauges work fine. The dash lights worked last summer but now nothing, that makes me think maybe fuse or bad ground, Is it possible for all the bulbs to just burn out at once? I work a lot so its not really feasible for be to take the dash out right now just to replace some bulbs…possible bad dimmer switch,? Is there any way to test it?

--Thanks for the input
 

6880 Mike

Well-known member
Joined
Jun 30, 2006
Messages
2,723
Location
The Bluegrass State
Corvette
1968 convertible; 1980 L-82
#1 culprit would be the fuse. Pull it and check it. Check it extremely well because I've seen bad ones which were not visible in the panel, but showed a tiny break when pulled and looked at in better lighting conditions.

If the fuse is okay, check the rheostat on the light switch. These can wear with age and take out the instrument lights.

It isn't likely all the lamps would fail at the same time unless you had a heckuva shot of current through the system. Had that happened, you'd have probably seen (and smelled) smoke after you heard the pop.
:)
 
J

jmp

Guest
I have a similar problem with my '72, but in my case the fuse keeps blowing.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom