Welcome to the Corvette Forums at the Corvette Action Center!

Oil Temperature Sensor

LannyL81

Well-known member
Joined
Jul 20, 2002
Messages
653
Location
Oro Valley, AZ USA
Corvette
81 White/Cinnabar, 96 CE LT4 sil/blk
Greetings everyone,
Last weekend project was to replace the stock AM/FM radio with the optional AM/FM/Cass factory radio...the one with a digital clock in the display. So I had purchased an entire set of gauges and a new bezel for one with the oil temp gauge instead of the clock.
Got everything in and actually the fuel gauge works better...no bouncing needle...have found both electrical connectors for the oil temp sensor...

BUT

not having any luck getting the plug out of the engine block above the oil filter to put the oil temp sensor in. I though for sure that by driving around for an hour to get it all nice and hot would let me remove it...nope. So am going to try a propane torch on the plug this weekend. Is this the right approach....or is there something else I should do???????????????

Thanks,
Lannyl81 (I want Hooker headers and sidepipes.....blasted emissions...)
 

bill81vette

Moderator
Joined
Jan 17, 2004
Messages
4,321
Location
Troy,NY
Corvette
1981 dark blue metallic
Lanny, Last time I did one,it was towards the back of the intake,near the distributor,and it screwed into the intake,I'm not sure where you are refering to????
 

craig32

Well-known member
Joined
Sep 30, 2004
Messages
482
Location
PA
Corvette
1981 repainted black coupe
That's for Oil PRESSURE, Bill. Not really familiar with oil Temp, even tho my Vette has one. Now I'll have to look come daylight!

Craig
 

LannyL81

Well-known member
Joined
Jul 20, 2002
Messages
653
Location
Oro Valley, AZ USA
Corvette
81 White/Cinnabar, 96 CE LT4 sil/blk
It figures......

Well....right before I was going to lite the torch and apply heat to the plug for the oil temp sensor...thought I would give it one more try.....and it turned very easily....???????....
Now this is the same plug that I have pulled and tuged and pulled some more...and I got it to move just a bit but then it stopped. I was afraid if I pulled any harder it was going to shear off.
When I got the plug out took a good look at it and saw that the threads were pretty well messed up...surprised it came out of the block...
Oh well....now its off and I installed the oil temp sensor, went right in, no problems.

Anyone know what the thread pitch is on the oil temp sensor? Would like to re-thread that plug to have just in case I need to put in back in for some reason. I measured it and its either 1/2" or 14mm...but the threads are so messed up that I cannot get a good reading on the pitch.

Another project complete....but I still want side pipes and headers........

Thanks,
LannyL81
 

bill81vette

Moderator
Joined
Jan 17, 2004
Messages
4,321
Location
Troy,NY
Corvette
1981 dark blue metallic
I read it wrong!!!:hb Oh well.....
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom