Welcome to the Corvette Forums at the Corvette Action Center!

Rattle

Bobs1977

Member
Joined
Sep 17, 2002
Messages
14
Location
Ft.Wayne in/port st lucie fl
Corvette
91 red coupe
My 91 coupe with 13k miles has a ratle that i can't locate somewhere in the underbody. I've checked for a loose exhaut, heat shields,replaced the shocks, checked the u joints ,dropped the spare tire and jack ,emptied all the storage comp and bins,It doest seem to be speed sensitive. It seems to be coming from rear of the passenger compartment. I'm stumped...
 

lone73

Well-known member
Joined
Sep 24, 2003
Messages
456
Location
Texas
Corvette
'73 4spd coupe, '04 6 speed coupe
Bob,
I had a similar problem on my '96. Had a really bad rattle in the rear. Looked for months for it. Finally found that the rubber isolators in the mounts for the rear sway bar had worn out on the right hand side allowing metal to metal contact. They couldn't be viewed directly. I think I had to remove the mounting bolt in the end link to allow it to move up where I could actually see the rubber part.

Just saw that your car has 13K miles. Probably not a sway bar mount but if you've tried everything else...what the heck. Doesn't take long to check.

good luck with it
.
.
.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Win Both Corvettes!

Win Both Corvettes and Get Extra Bonus Tickets Now!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Dead Center Foundation

Vetteskins

Advertise with the Corvette Action Center!

Partners

Top Bottom