Welcome to the Corvette Forums at the Corvette Action Center!

1984 corvette in need of help

In need of help

New member
Joined
May 28, 2016
Messages
1
Location
Mobile Alabama
I have just bought a1984 corvette that has setup for around 3 years the car was running fine when it was parked with that being said I turn the key on all dashboard lights up but the starter will not spin over at all all so the injectors are not getting power I hooked up a pushbutton switch from the battery to the ignition wire on the starter poured some gas in the throttle body's hit the pushbutton and she fire's right up and runs until it burns the gas that I poured in it. I checked the fuel pump and filter every thing there is good i went ahead and changed the ignition cylinder hoping that might fix the problem but that didn't help the problem all the fuses are good i bought the ignition switch and am thinking of changing it next but it's going to be quite a job being you have to drop the column down and all that and there's surly no room under their to work i also have jumped the neutral safety switch and that didn't help the problem either i was wondering if this problem could be in a open circuit in one of the relays any information or help would be greatly appreciated I'm sure someone else out there has had this problem to thanks
 

Rob

Site Administrator
Staff member
Administrator
Joined
Sep 16, 2000
Messages
13,648
Location
New Hampshire
Corvette
1990 Corvette ZR-1
Welcome to the Corvette Action Center. I'm going to move your thread into the C4 tech forum for greater exposure...
 

ecss

Well-known member
Joined
Nov 27, 2004
Messages
649
Location
Windsor Mill, MD
Corvette
89 Brilliant Red Metallic
all the fuses are good i bought the ignition switch and am thinking of changing it next but it's going to be quite a job being you have to drop the column down and all that and there's surly no room under their to work i also have jumped the neutral safety switch and that didn't help the problem either i was wondering if this problem could be in a open circuit in one of the relays any information or help would be greatly appreciated I'm sure someone else out there has had this problem to thanks

Assuming there is no aftermarket alarm installed.

You need to gain access to the starter interrupt relay located behind the DIC driver information center.
Below is a picture of the relay.

If you remove the relay and jump the Purple wire which goes to the starter solenoid to the Dark Green/White wire which goes to the neutral safety switch and turn the ignition switch to start the starter should engage.

If it doesn't you need to verify there is 12 volts on the Yellow wire of the Neutral Safety switch when the ignition switch is in Start.

If no 12 volts, probably the ignition switch is bad or it's not adjusted correctly. It's mounted on the steering column and can be moved up and down.

If the starter does engage when you jump the Dark Green/White wire to the Purple wire when you turn the ignition to start, something is wrong with the Theft Deterrent Module. It energizes the starter interrupt relay if the alarm is set and either door or hatch is opened and disables the starter.



 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom