Welcome to the Corvette Forums at the Corvette Action Center!

ahhh headlight fun

wrc3

Well-known member
Joined
Mar 18, 2002
Messages
228
Location
Arlington, VA
Corvette
1976 L-48
So finally got the vacuum system working so the lights pop up nicely. Only problem is that when I turn them off the drivers side light goes down and then about about a 2 second pause the passenger side goes down. Any ideas?

B
 

jdp6000

Well-known member
Joined
Aug 23, 2004
Messages
646
Location
Aurora, Ontario, Canada
Corvette
1982 CROSSFIRE
I have the same problem. I'm not sure what the solution is. I think it may have to do with the distribution valve mounted on the header between the lights. Let us know what you find out.

Jim
 

Vettehead Mikey

Well-known member
Joined
Aug 26, 2003
Messages
3,486
Location
Not that far from Ottawa
Corvette
1973 Coupe
This is a sign that you may still have a leak somewhere. Could be anywhere, the system needs to be at full engine vacuum to really snap the lights open and closed like when the car was new.
 

wrc3

Well-known member
Joined
Mar 18, 2002
Messages
228
Location
Arlington, VA
Corvette
1976 L-48
This is a sign that you may still have a leak somewhere. Could be anywhere, the system needs to be at full engine vacuum to really snap the lights open and closed like when the car was new.

I think you are right. The vacuum hadn't had time to really get going. After getting in the car last night and driving around for about 30 minutes the lights went up and down as expected.

Just a note when I first was troubleshooting the system I replaced the hoses and the actuators and nothing. After taking some time and thinking about it again I put one of my old actuators back in and it worked. So I grabbed another acutator and it worked fine too. The two actuators I had gotten brand new from Ecklers were both non-functioning. I have since gotten a vacuum hand pump and tested and sure enough they don't work. Just terrible production value in my opinion.

B
 

Bill75

Well-known member
Joined
Jan 1, 2004
Messages
698
Location
Somers CT
Corvette
75 Coupe ZZ4, Brodix IK-180's, Headers,TK0-500
The two actuators I had gotten brand new from Ecklers were both non-functioning. I have since gotten a vacuum hand pump and tested and sure enough they don't work. Just terrible production value in my opinion.

B

Wow, that's enough to make your blood boil for sure!!!!

Another spot that's prone to leaking is the seal on the actuator shaft on the vacuum canister. I brought one of mine back to life by changing it, about $8 vs $100. Mine was real slow coming up and took a long time to get to the lock position. Works fine now.
 
J

juggler

Guest
Another spot that's prone to leaking is the seal on the actuator shaft on the vacuum canister.

Can you give me an idea where that's located? I am in the process of ordering a service manual for my '76, but unitl it comes in I am using a Chilton's to locate things.

My lights will come up OK, but the passenger side will either not go down or work sporadically.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom