Welcome to the Corvette Forums at the Corvette Action Center!

Help with weird rear wheel noise

89Z51

Member
Joined
Apr 26, 2011
Messages
23
Location
Wisconsin
Corvette
2008 Z06
Good/bad hub?

You'll want to check for play in the hub before removal. Once removed, feel for smooth rotation (no rough or tight spots). I agree with the comment about replacing the u-joints while you're in there. My hubs outlasted the u-joints, but I changed all at the same time while I had everything apart. Regarding the nut, I'm sure it is metric. However, all my "monster" sockets are english sizes and I was able to use them without a problem.
 

chevyaddict

Well-known member
Joined
Jun 12, 2002
Messages
894
Location
Tucson, AZ USA
Corvette
1990 Convertible
I've been posting to other threads about this but since Hib posted here I thought I'd update here to see if he has any more advice. I've been sitting here now for about two hours reading through ALL the forum posts concerning this issue. First, I can't get the damn hub nut off - but besides that, with everything I've now read, even though it sounds like the hub assembly I have NO PLAY at all in them. NO PLAY. I've done the shaker test about six times now. Everyone else seems to have had some kind of play and that was their indicator. I am having this metal-on metal rotational sound idling down the road, and it does get worse if I accelerate. Doesn't matter if I go left to right. I want it to be the u-joints but I'm having a hard time imagining how a u-joint can sound like a metal-on-metal sound.

So since I can't get the damn hub nut off no matter what I try, I guess I'm going to remove the half shaft and just see if its the u-joints and HOPE that is actually the problem so I can put off hub bearing replacement until some point in the future! I'll keep ya'll posted.....
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
The half shaft will not come out

UNLESS you just remove the U joint clamps and that a bit of a job....
 
A

abigtroutt

Guest
I have an 84 C4 and had the same noise from the rear passenger side tire. At first I though it may have been the rear hub but after I took the tire, brakes, and caliper off, I found it was the emergency brake spring which broke then tore every thing else up. Easy fix but hard to find the replacement parts. All were on back order. Not to big of an issue cause I just removed all the parts to the emergency brakes and no more noise and runs great. Just waiting to parts to be back in stock and I just don't use the emergency brake.
 

chevyaddict

Well-known member
Joined
Jun 12, 2002
Messages
894
Location
Tucson, AZ USA
Corvette
1990 Convertible
Just got the half shaft out and guess what? It is a bad u-joint! I'm so excited actually! Kinda of a pain in the butt job but at least I've found the problem! Thanks everyone for all your help!
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Advertise with the Corvette Action Center!

Double Your Chances!

Our Partners

Top Bottom