Welcome to the Corvette Forums at the Corvette Action Center!

I need some fast help guy's

S

Shadowing1985v

Guest
ok here is the deal,, i finally fixed my oil leaks

and i painted my engine chrome and black

and i just put it all back together...
and now im ready to finally fix what is wrong with my corvette.

i hooked the timing lite on it today and i got it really close
but its back firing i think
what causes back firing?

i moved my tps sensor a long time ago"wish i wouldn't of" well i replaced it also.
can tps be making it do this,"i wouldn't think it would"
anyways i got the mark really close. ran out of time, will work on it sunday. i disscounted what i thought was the ecm signal its a round plug right? on driver side near firewall

please help with suggestions, it says my timing needs to be 6 degrees on an automatic tranny. what am I doing wrong
 
S

Shadowing1985v

Guest
almost forgot

its a 85
C4

i do need new spark wires
going t buy them real soon.
cause they are in really bad shape

my spark plugs are gaped .035 or what ever the books says
and im running rapid fires bosch or what ever that brand name is.
my ECM is brand new and my ICM is brand new. EGR valve and seneroid is brand new. new tps. new eletric spark module new knock sensor and new OS sensor

thats all i replace so far cause i was dumb when i replaced those when i didn't know much about cars, hehe
but those are my facts
 

-=Jeff=-

Well-known member
Joined
Feb 2, 2001
Messages
909
Location
Bartlett, IL. (Chicago Suburb)
Corvette
1990 ZR-1
Replace the wires, first then try to set the timing..

Also be sure the TPS at idle is around .58 volts
 
B

biceps1

Guest
Sounds like timing to me. Did you disconnect the HEI/EST bypass before you timed your vette? If you do that, and then set base timing to 6Degrees BTDC you should cure the backfire problem.

6* before top dead center is what the factory recommends on initial timing on the 85's

biceps1
gold 85 coupe
 
S

Shadowing1985v

Guest
kewl

im going out side right now to set my TPS

it says in my book it needs to be reading of 0.54 ^ 0.075

i don't understand what that means

does it need to read .54 or .075,, sigh

i figure its .54 since that one guy says .58
 
S

Shadowing1985v

Guest
ok,, thats done

i made 3 jumper wires
and tested my tps out,, it was reading 78 volts

big diffferance

so now i spent 20 mintues making it exactly 54 volts

well it was 54 to 55

but thats pretty close, close enough i would think

so that problem is done,,

my car is jumping big time it will go down to 500 rpm's then the car will self raise its self to 1200 then it will lower to 54 then to 1200 so i guess this si timing,, probably
 
S

Shadowing1985v

Guest
ok i bought my wires,, putting them on now

it turns out,, my dad thinks the guy that put my engine together
didnt' put it on the right tooth or something,, making it wear i can't time it correctly

so he said all i ahve to do is just move my spark plugs over one and that will fix it

is this true will this work?
 

-=Jeff=-

Well-known member
Joined
Feb 2, 2001
Messages
909
Location
Bartlett, IL. (Chicago Suburb)
Corvette
1990 ZR-1
Re: kewl

Shadowing1985v said:
im going out side right now to set my TPS

it says in my book it needs to be reading of 0.54 ^ 0.075

i don't understand what that means

does it need to read .54 or .075,, sigh

i figure its .54 since that one guy says .58

TPS should be .54 +/- .75.. So as low as .465 or as high as .615

I have mine around .58 and have had no problems
 

Paul G

Well-known member
Joined
Aug 27, 2001
Messages
200
Location
Griffith, IN, USA
Corvette
96 CE LT4 Convertible
If things were recently apart and the engine is surging I would check for some major vacuum leaks.
 
S

Shadowing1985v

Guest
well

i just broke my cold start valve

now i have to wait a week to replace it do to the auto place not having one near by
 
8

86Gold

Guest
Two pieces of info that may help.

Was the harmonic balancer replaced when the engine was rebuilt? Mine had started to fall apart and the outer ring (with timing mark) had slipped. So when I was timing it I was way off and didn't know it.

After I replaced my fuel injectors, recently, I had a surge during idle like you described. I searched for vacuum leaks for days. I finally reset the minimum air at idle (opened it up) and the surge went away.

Just some thoughts.

Good luck.
 
S

Shadowing1985v

Guest
ok,, thanks for the infro,, i have replaced my balancer it broke on me at 200K miles

ok guy's,,
my engine is backtogether i fixed the huge vaccume leak

but i still have to go intown and buy a screw for a screwhole that goes into my runner so there won't be a leak there
but i started it and that leak isn't a big one

anyways i put new wires on it and fix that tps
and th timing is 6 degrees
now is my tming suppose to be 6 degrees whitch way?? anyone know

anywyas my car idles really nice now
but i forgot how the corvette suppose to rtatle
the engine sits there and shakes a little
i have no miss firing or back firing thats all fixed now
tomorrow i will see if I can get it to 400 rpms in drive
its an auto tranny
should it stay at 400 like 399 to 401 imean or should the idle be so good that it should be right on 400
 
Joined
Oct 30, 2001
Messages
2,273
Location
Glen Burnie, MD, USA
Corvette
1986 Bright Red Coupe
6 degrees BEFORE top-dead-center. That means, IIRC, that the timing mark should be three notches above the centermark on the balancer as you look at it from the driver's side fender.
[RICHR]
 
S

Shadowing1985v

Guest
ok guy's

i have it on 6 degrees now

i go to turn the idle screw thing and i screwed it as far as it can go and i can only get it to 550 rpm's in drive

im going out side to start pulling spark plugs to see if i have some bad injectors
 

topless82vette

Well-known member
Joined
Nov 1, 2001
Messages
910
Location
southern california
Corvette
1982 convertible (not factory) stock 350cfi auto
shadow

maybe after all a crossfire car would have been a better choice huh, seems tpi has problems too huh do you think your awsome tpi car keep up with my nice running crossfire engine now LOLOLOLOL have a nice day ..... think I will go for a nice cruise hahaha
 
S

Shadowing1985v

Guest
hehe,,, funny

i guess it turns out my altnator is bad

reason my car had no horse power from start out

my car was only getting 10.5
 
D

Drewser

Guest
yeah,,,hehe,,me too

Hey Nadsdow--Meand Topless82vette are goin for a cruzzz in r,,,hehe,,,crappy crossfires that happen to run,,,hehe so you leik wanna go? Oh that's right, your supercar is all broken.:( I don't know why you didn't just buy a 95 instead of an 85 since all vettes are the same leik pricehehe
 

topless82vette

Well-known member
Joined
Nov 1, 2001
Messages
910
Location
southern california
Corvette
1982 convertible (not factory) stock 350cfi auto
shadow

I have a nice crossfire injection system you could throw on your car to get rid of the tuned port injection problems

have a nice day shadow
 
S

Shadowing1985v

Guest
umm

tune port is better

u are arguing agaist physics



u don't see brand new vetts with cross fire
 
S

Shadowing1985v

Guest
corvettes are a dime a dozen where i live in missouri

they all cost 5500 and less
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom