Welcome to the Corvette Forums at the Corvette Action Center!

Ride Control service light

S

searay270

Guest
I recently received a "service ride control" light (right side, middle) after starting the engine on my Ruby 93 with selective ride option - it stayed on and never went out. I shut off the engine, restarted, and it did not stay on or go on thereafter. Drove it for a half hour and everything seems OK.

I checked the forum and the service manual ECM volume 2 - nothing.

Any thoughts as to the cause of the light staying on just this one time? The only work done recently by me or anyone else was to fix the lumbar seat pumps, and check the air cleaner element! The car had two uneventful runs since the air cleaner chedc prior to the light staying on.

Thanks.

Jack
Sarasota, FL
 

Rabbit

Well-known member
Joined
Dec 19, 2001
Messages
956
Location
sonoma ca usa
Corvette
2004 C5 coupe, MSGM & 2014 Cad SRX Crystal red
It may indicate a future problem. Just keep driving & see what happens. Even if the code returns it will have no effect on the driveability. I can e-mail you some info re: FX3 if you like? :s :dance
 

rdgfx3

Well-known member
Joined
Jul 25, 2001
Messages
202
Location
Rowlett,TX.
Corvette
2008 Silver Coupe
If you are doing work on the car and turn the ignition on and off three times(I think it's three)the light will come on and stay on until the car is driven.
I just had my Selective Ride Control system refreshed.Bilstein rebuilt the shocks($100.00 each. Was $55.00 each)and replaced all actuators.

BTW,actuators are becoming scarce for this system.GM is getting TOP DOLLAR.I was forced to buy (ahem) recycled actuators.

Oh,there is a site that vaugley tells how to rebuild your actuators.Email me for the link.I screwed up the first one 'cause I cut it in the wrong place,so I just bit the bullet and bought(ahem)recycled actuators.:w
 
S

secondchance

Guest
If you don't mind, I would like the same info also. Thanks.
 
9

90coupe

Guest
service ride control light

My light does come on occasionally. The shocks aren't leaking and seem to work fine but the light still comes on perhaps every 5th or 6th time I drive the car. Any info would be appreciated!

:w
 
S

searay270

Guest
Thanks for the replies

The second post above about turning the ignition on/off three times without starting the car is probably the answer. I had recently gotten done replacing the CD/radio head unit from a Dr. Don repair (super service, by the way), testid it and cycled the ignition several times as the door-closed timout expired.

The trip out of the garage where the light stayed on was the first time since going through all this.

I did check tire pressures @4, and all was OK. Have not driven car since, but will watch for the light as suggested.

Thanks to all for your ideas.

Jack
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom