Welcome to the Corvette Forums at the Corvette Action Center!

Transmission or linkage

pack84

Well-known member
Joined
Oct 15, 2006
Messages
50
Location
texas
Corvette
1984blue coupe
On my 1985 C4 vette I was pulling in to park and it would not go into park. It will go into all other gears just not park. Is that the transmission or the linkage?
 

vee93

Well-known member
Joined
Nov 15, 2002
Messages
585
Location
Mississippi
Corvette
1993 Medium Quasar Blue Metallic Coupe
Sounds like a linkage problem. Usually, if you're shifting into gears, a tranny problem would be if you couldn't back out of say..., a parking space and you suddenly found you had no reverse. Or you're at a stop sign, step on the gas and you're not moving although you're in D.
Go ahead and check your fluids.
I had a problem corrected where I'd put the Vette in park and it wanted to keep going backwards or forward, depending on the level of the street. I had to use the park brake to make sure it wouldn't move. Good thing I noticed it before I hit the gas for revs while parked in front of someone!!!
Turns out a bolt had fallen completely out of the shifter control cable where it attaches to the transmission. It was about a 40 minute fix.
Hope this helps. :w
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Advertise with the Corvette Action Center!

Double Your Chances!

Our Partners

Top Bottom