Welcome to the Corvette Forums at the Corvette Action Center!

troubleshooting wiper problem on an 80

80convertible

Well-known member
Joined
Jan 26, 2001
Messages
416
Location
Asheville, NC
Corvette
1973 converted to 1980 custom convertible
Trying to get my wipers working. They were working until recently. Not sure what happened. With ignition in on position I have no 12 volt at wiper motor connection. Checked fuse and it is fine as there is 12 volt power at the fuse block. Should I assume the wiper switch decided to quit on me? If not, what else to consider? Any tips on troubleshooting would be greatly appreciated!

Regards,

Jim
 
Joined
Nov 4, 2000
Messages
947
Location
Scottsville, Kentucky
Corvette
08 Jetstream Blue Z51 coupe
With no power at the motor but power at the fuse I suspect the switch. It looks like the trim piece around the switch pulls off. If it doesn't give you good access then I suspect that you may have to remove the screws from the speedometer and tach assembly and lay them ahead out of the way.
 

78Ragtop

Member
Joined
Jun 14, 2001
Messages
11
Location
Canada
Corvette
1978 custom
I had a short in my wiper switch once - took me 2 weeks to track it down. I was able to take the housing apart, clean the switch and put it back together again. It was very simple to do.

Hope this helps.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Win Both Corvettes!

Win Both Corvettes and Get Extra Bonus Tickets Now!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Dead Center Foundation

Vetteskins

Advertise with the Corvette Action Center!

Partners

Top Bottom