Welcome to the Corvette Forums at the Corvette Action Center!

Found my Problem! Both of em!

BigRed

Well-known member
Joined
May 23, 2001
Messages
948
Location
Edmonton
Corvette
1985 Bright Red Rocket
Dash Cluster:

Halogens wont turn on and signals and bright light stay on (Solid no flashing unless I ask them to)

I checked and double checked the wires..Nothing
I checked and cleaned the pins/plug..Nothing

So I went in put on my surgical gloves asked for a scalpel and tore apart the cluster well would you look at that!

The bottom circut board (Which holds all the light bulbs) has a path that connects all the bulbs then leaves the board in the form of a pin to the second lvl circut board. Now on the second board there is a plug looking mount for these pins! well well well look at the charred plastic! one of the pins (Happens to be the one for the lights) had lost its connection to the top board and has been ARCING out (hence the charred white plastic)!!!!!

So instead of a expensive rebuild or replacement I showed it to my buddy Dave (Owner of a Electronic Repair shop) and he laughed (Told me what a good problem solver I was LOL) and is going to repair it for like 30 bucks CND!

Bigred <----Happy Camper!! :L

Starting problems

Flat out IT IS THE STARTER Mechanic looked at it, heard it, looked at me, made a face, then laughed (Ars!) Being fixed as I speak :bu
 
S

Shadowing1985v

Guest
yeah tell me about it

im trying to figure out why my altnator isn't showing more then 10.5 volts


the alt is good too i had it tested
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom